source: proiecte/PPPP/gdm/debian/patches/24_system_uid.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 2.5 KB
RevLine 
[134]1#
2# Description:  Ignore users with UID < 1000
3# Ubuntu: https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/427462
4#
5diff -Nur -x '*.orig' -x '*~' gdm-2.28.0/daemon/gdm-user-manager.c gdm-2.28.0.new/daemon/gdm-user-manager.c
6--- gdm-2.28.0/daemon/gdm-user-manager.c        2009-10-14 18:31:35.000000000 +1100
7+++ gdm-2.28.0.new/daemon/gdm-user-manager.c    2009-10-14 18:34:59.000000000 +1100
8@@ -66,7 +66,7 @@
9 #ifdef __sun
10 #define DEFAULT_MINIMAL_UID     100
11 #else
12-#define DEFAULT_MINIMAL_UID     500
13+#define DEFAULT_MINIMAL_UID     1000
14 #endif
15 
16 #ifndef _PATH_SHELLS
17@@ -539,6 +539,10 @@
18                 return;
19         }
20 
21+        if (pwent->pw_uid < DEFAULT_MINIMAL_UID) {
22+                return;
23+        }
24+
25         /* check exclusions up front */
26         if (g_hash_table_lookup (manager->priv->exclusions, pwent->pw_name)) {
27                 g_debug ("GdmUserManager: excluding user '%s'", pwent->pw_name);
28diff -Nur -x '*.orig' -x '*~' gdm-2.28.0/gui/gdmsetup/gdm-user-manager.c gdm-2.28.0.new/gui/gdmsetup/gdm-user-manager.c
29--- gdm-2.28.0/gui/gdmsetup/gdm-user-manager.c  2009-10-14 18:31:34.000000000 +1100
30+++ gdm-2.28.0.new/gui/gdmsetup/gdm-user-manager.c      2009-10-14 18:33:38.000000000 +1100
31@@ -66,7 +66,7 @@
32 #ifdef __sun
33 #define DEFAULT_MINIMAL_UID     100
34 #else
35-#define DEFAULT_MINIMAL_UID     500
36+#define DEFAULT_MINIMAL_UID     1000
37 #endif
38 
39 #ifndef _PATH_SHELLS
40@@ -835,6 +835,10 @@
41                 return;
42         }
43 
44+        if (pwent->pw_uid < DEFAULT_MINIMAL_UID) {
45+                return;
46+        }
47+
48         /* check exclusions up front */
49         if (g_hash_table_lookup (manager->priv->exclusions, pwent->pw_name)) {
50                 g_debug ("GdmUserManager: excluding user '%s'", pwent->pw_name);
51diff -Nur -x '*.orig' -x '*~' gdm-2.28.0/gui/simple-greeter/gdm-user-manager.c gdm-2.28.0.new/gui/simple-greeter/gdm-user-manager.c
52--- gdm-2.28.0/gui/simple-greeter/gdm-user-manager.c    2009-10-14 18:31:35.000000000 +1100
53+++ gdm-2.28.0.new/gui/simple-greeter/gdm-user-manager.c        2009-10-14 18:34:14.000000000 +1100
54@@ -66,7 +66,7 @@
55 #ifdef __sun
56 #define DEFAULT_MINIMAL_UID     100
57 #else
58-#define DEFAULT_MINIMAL_UID     500
59+#define DEFAULT_MINIMAL_UID     1000
60 #endif
61 
62 #ifndef _PATH_SHELLS
63@@ -909,6 +909,10 @@
64                 return;
65         }
66 
67+        if (pwent->pw_uid < DEFAULT_MINIMAL_UID) {
68+                return;
69+        }
70+
71         /* check exclusions up front */
72         if (g_hash_table_lookup (manager->priv->exclusions, pwent->pw_name)) {
73                 g_debug ("GdmUserManager: excluding user '%s'", pwent->pw_name);
Note: See TracBrowser for help on using the repository browser.