source: proiecte/PPPP/gdm/debian/patches/24_system_uid.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 2.5 KB
  • daemon/gdm-user-manager.c

    #
    # Description:  Ignore users with UID < 1000
    # Ubuntu: https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/427462
    #
    diff -Nur -x '*.orig' -x '*~' gdm-2.28.0/daemon/gdm-user-manager.c gdm-2.28.0.new/daemon/gdm-user-manager.c
    old new  
    6666#ifdef __sun
    6767#define DEFAULT_MINIMAL_UID     100
    6868#else
    69 #define DEFAULT_MINIMAL_UID     500
     69#define DEFAULT_MINIMAL_UID     1000
    7070#endif
    7171
    7272#ifndef _PATH_SHELLS
     
    539539                return;
    540540        }
    541541
     542        if (pwent->pw_uid < DEFAULT_MINIMAL_UID) {
     543                return;
     544        }
     545
    542546        /* check exclusions up front */
    543547        if (g_hash_table_lookup (manager->priv->exclusions, pwent->pw_name)) {
    544548                g_debug ("GdmUserManager: excluding user '%s'", pwent->pw_name);
  • gui/gdmsetup/gdm-user-manager.c

    diff -Nur -x '*.orig' -x '*~' gdm-2.28.0/gui/gdmsetup/gdm-user-manager.c gdm-2.28.0.new/gui/gdmsetup/gdm-user-manager.c
    old new  
    6666#ifdef __sun
    6767#define DEFAULT_MINIMAL_UID     100
    6868#else
    69 #define DEFAULT_MINIMAL_UID     500
     69#define DEFAULT_MINIMAL_UID     1000
    7070#endif
    7171
    7272#ifndef _PATH_SHELLS
     
    835835                return;
    836836        }
    837837
     838        if (pwent->pw_uid < DEFAULT_MINIMAL_UID) {
     839                return;
     840        }
     841
    838842        /* check exclusions up front */
    839843        if (g_hash_table_lookup (manager->priv->exclusions, pwent->pw_name)) {
    840844                g_debug ("GdmUserManager: excluding user '%s'", pwent->pw_name);
  • gui/simple-greeter/gdm-user-manager.c

    diff -Nur -x '*.orig' -x '*~' gdm-2.28.0/gui/simple-greeter/gdm-user-manager.c gdm-2.28.0.new/gui/simple-greeter/gdm-user-manager.c
    old new  
    6666#ifdef __sun
    6767#define DEFAULT_MINIMAL_UID     100
    6868#else
    69 #define DEFAULT_MINIMAL_UID     500
     69#define DEFAULT_MINIMAL_UID     1000
    7070#endif
    7171
    7272#ifndef _PATH_SHELLS
     
    909909                return;
    910910        }
    911911
     912        if (pwent->pw_uid < DEFAULT_MINIMAL_UID) {
     913                return;
     914        }
     915
    912916        /* check exclusions up front */
    913917        if (g_hash_table_lookup (manager->priv->exclusions, pwent->pw_name)) {
    914918                g_debug ("GdmUserManager: excluding user '%s'", pwent->pw_name);
Note: See TracBrowser for help on using the repository browser.