source: proiecte/PPPP/gdm/debian/patches/23_login_window_hint.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 1.1 KB
RevLine 
[134]1#
2# Description: Don't use the DOCK hint on the login window as this stops it from getting keyboard focus
3# Ubuntu: https://bugs.launchpad.net/gdm/+bug/447049
4# Upstream: https://bugzilla.gnome.org/show_bug.cgi?id=598235
5#
6diff -Nur -x '*.orig' -x '*~' gdm-2.28.0/gui/simple-greeter/gdm-greeter-login-window.c gdm-2.28.0.new/gui/simple-greeter/gdm-greeter-login-window.c
7--- gdm-2.28.0/gui/simple-greeter/gdm-greeter-login-window.c    2009-10-13 15:54:50.000000000 +1100
8+++ gdm-2.28.0.new/gui/simple-greeter/gdm-greeter-login-window.c        2009-10-13 15:55:38.000000000 +1100
9@@ -1739,7 +1739,7 @@
10         gtk_window_set_skip_taskbar_hint (GTK_WINDOW (login_window), TRUE);
11         gtk_window_set_skip_pager_hint (GTK_WINDOW (login_window), TRUE);
12         gtk_window_stick (GTK_WINDOW (login_window));
13-        gtk_window_set_type_hint (GTK_WINDOW (login_window), GDK_WINDOW_TYPE_HINT_DOCK);
14+        /*gtk_window_set_type_hint (GTK_WINDOW (login_window), GDK_WINDOW_TYPE_HINT_DOCK);*/ /* Docks cannot get focus */
15         gtk_container_set_border_width (GTK_CONTAINER (login_window), 0);
16 
17         g_signal_connect (login_window,
Note: See TracBrowser for help on using the repository browser.