source: proiecte/PPPP/gdm/debian/patches/23_login_window_hint.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 1.1 KB
  • gui/simple-greeter/gdm-greeter-login-window.c

    #
    # Description: Don't use the DOCK hint on the login window as this stops it from getting keyboard focus
    # Ubuntu: https://bugs.launchpad.net/gdm/+bug/447049 
    # Upstream: https://bugzilla.gnome.org/show_bug.cgi?id=598235
    #
    diff -Nur -x '*.orig' -x '*~' gdm-2.28.0/gui/simple-greeter/gdm-greeter-login-window.c gdm-2.28.0.new/gui/simple-greeter/gdm-greeter-login-window.c
    old new  
    17391739        gtk_window_set_skip_taskbar_hint (GTK_WINDOW (login_window), TRUE);
    17401740        gtk_window_set_skip_pager_hint (GTK_WINDOW (login_window), TRUE);
    17411741        gtk_window_stick (GTK_WINDOW (login_window));
    1742         gtk_window_set_type_hint (GTK_WINDOW (login_window), GDK_WINDOW_TYPE_HINT_DOCK);
     1742        /*gtk_window_set_type_hint (GTK_WINDOW (login_window), GDK_WINDOW_TYPE_HINT_DOCK);*/ /* Docks cannot get focus */
    17431743        gtk_container_set_border_width (GTK_CONTAINER (login_window), 0);
    17441744
    17451745        g_signal_connect (login_window,
Note: See TracBrowser for help on using the repository browser.