source: proiecte/PPPP/gdm/debian/patches/12_fusa_name_change.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 2.3 KB
RevLine 
[134]1#
2# Description: Change Bonobo activation server name to avoid conflict with indicator-session
3# Ubuntu: https://bugs.edge.launchpad.net/ubuntu/+source/gdm/+bug/410498
4#
5diff -ur gdm-2.27.4/gui/user-switch-applet/applet.c gdm-ted/gui/user-switch-applet/applet.c
6--- gdm-2.27.4/gui/user-switch-applet/applet.c  2009-07-20 02:09:09.000000000 +0100
7+++ gdm-ted/gui/user-switch-applet/applet.c     2009-08-07 22:29:45.000000000 +0100
8@@ -101,7 +101,7 @@
9                                 const char    *iid,
10                                 gpointer       data);
11 
12-PANEL_APPLET_BONOBO_FACTORY ("OAFIID:GNOME_FastUserSwitchApplet_Factory",
13+PANEL_APPLET_BONOBO_FACTORY ("OAFIID:GNOME_FastUserSwitchAppletGdm_Factory",
14                              PANEL_TYPE_APPLET,
15                              "gdm-user-switch-applet", "0",
16                              (PanelAppletFactoryCallback)applet_factory,
17@@ -1619,7 +1619,7 @@
18 {
19         gboolean ret;
20         ret = FALSE;
21-        if (strcmp (iid, "OAFIID:GNOME_FastUserSwitchApplet") == 0) {
22+        if (strcmp (iid, "OAFIID:GNOME_FastUserSwitchAppletGdm") == 0) {
23                 ret = fill_applet (applet);
24         }
25         return ret;
26diff -ur gdm-2.27.4/gui/user-switch-applet/GNOME_FastUserSwitchApplet.server.in.in gdm-ted/gui/user-switch-applet/GNOME_FastUserSwitchApplet.server.in.in
27--- gdm-2.27.4/gui/user-switch-applet/GNOME_FastUserSwitchApplet.server.in.in   2009-05-19 16:18:12.000000000 +0100
28+++ gdm-ted/gui/user-switch-applet/GNOME_FastUserSwitchApplet.server.in.in      2009-08-07 22:28:29.000000000 +0100
29@@ -1,5 +1,5 @@
30 <oaf_info>
31-  <oaf_server iid="OAFIID:GNOME_FastUserSwitchApplet_Factory" type="exe"
32+  <oaf_server iid="OAFIID:GNOME_FastUserSwitchAppletGdm_Factory" type="exe"
33               location="@LIBEXECDIR@/gdm-user-switch-applet">
34 
35     <oaf_attribute name="repo_ids" type="stringv">
36@@ -18,8 +18,8 @@
37     </oaf_attribute>
38   </oaf_server>
39 
40-  <oaf_server iid="OAFIID:GNOME_FastUserSwitchApplet" type="factory"
41-              location="OAFIID:GNOME_FastUserSwitchApplet_Factory">
42+  <oaf_server iid="OAFIID:GNOME_FastUserSwitchAppletGdm" type="factory"
43+              location="OAFIID:GNOME_FastUserSwitchAppletGdm_Factory">
44 
45     <oaf_attribute name="repo_ids" type="stringv">
46       <item value="IDL:GNOME/Vertigo/PanelAppletShell:1.0"/>
Note: See TracBrowser for help on using the repository browser.