source: proiecte/PPPP/gdm/debian/patches/12_fusa_name_change.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 2.3 KB
  • gui/user-switch-applet/applet.c

    #
    # Description: Change Bonobo activation server name to avoid conflict with indicator-session
    # Ubuntu: https://bugs.edge.launchpad.net/ubuntu/+source/gdm/+bug/410498
    #
    diff -ur gdm-2.27.4/gui/user-switch-applet/applet.c gdm-ted/gui/user-switch-applet/applet.c
    old new  
    101101                                const char    *iid,
    102102                                gpointer       data);
    103103
    104 PANEL_APPLET_BONOBO_FACTORY ("OAFIID:GNOME_FastUserSwitchApplet_Factory",
     104PANEL_APPLET_BONOBO_FACTORY ("OAFIID:GNOME_FastUserSwitchAppletGdm_Factory",
    105105                             PANEL_TYPE_APPLET,
    106106                             "gdm-user-switch-applet", "0",
    107107                             (PanelAppletFactoryCallback)applet_factory,
     
    16191619{
    16201620        gboolean ret;
    16211621        ret = FALSE;
    1622         if (strcmp (iid, "OAFIID:GNOME_FastUserSwitchApplet") == 0) {
     1622        if (strcmp (iid, "OAFIID:GNOME_FastUserSwitchAppletGdm") == 0) {
    16231623                ret = fill_applet (applet);
    16241624        }
    16251625        return ret;
  • gui/user-switch-applet/GNOME_FastUserSwitchApplet.server.in.in

    diff -ur gdm-2.27.4/gui/user-switch-applet/GNOME_FastUserSwitchApplet.server.in.in gdm-ted/gui/user-switch-applet/GNOME_FastUserSwitchApplet.server.in.in
    old new  
    11<oaf_info>
    2   <oaf_server iid="OAFIID:GNOME_FastUserSwitchApplet_Factory" type="exe"
     2  <oaf_server iid="OAFIID:GNOME_FastUserSwitchAppletGdm_Factory" type="exe"
    33              location="@LIBEXECDIR@/gdm-user-switch-applet">
    44
    55    <oaf_attribute name="repo_ids" type="stringv">
     
    1818    </oaf_attribute>
    1919  </oaf_server>
    2020
    21   <oaf_server iid="OAFIID:GNOME_FastUserSwitchApplet" type="factory"
    22               location="OAFIID:GNOME_FastUserSwitchApplet_Factory">
     21  <oaf_server iid="OAFIID:GNOME_FastUserSwitchAppletGdm" type="factory"
     22              location="OAFIID:GNOME_FastUserSwitchAppletGdm_Factory">
    2323
    2424    <oaf_attribute name="repo_ids" type="stringv">
    2525      <item value="IDL:GNOME/Vertigo/PanelAppletShell:1.0"/>
Note: See TracBrowser for help on using the repository browser.