source: proiecte/PPPP/gdm/debian/patches/10_xsplash.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 1.8 KB
RevLine 
[134]1#
2# Description: Load xsplash on login
3# Ubuntu: https://wiki.ubuntu.com/DesktopTeam/Specs/Karmic/LoginExperience
4#
5=== modified file 'data/Init.in'
6diff -Nur -x '*.orig' -x '*~' gdm-2.27.4/data/Init.in gdm-2.27.4.new/data/Init.in
7--- gdm-2.27.4/data/Init.in     2009-05-19 17:18:12.000000000 +0200
8+++ gdm-2.27.4.new/data/Init.in 2009-08-11 19:09:36.000000000 +0200
9@@ -6,6 +6,11 @@
10 PATH=@X_PATH@:$PATH
11 OLD_IFS=$IFS
12 
13+if [ -x '/usr/bin/xsplash' ];
14+then
15+        /usr/bin/xsplash --gdm-session --daemon
16+fi
17+
18 gdmwhich () {
19   COMMAND="$1"
20   OUTPUT=
21diff -Nur -x '*.orig' -x '*~' gdm-2.27.4/data/PreSession.in gdm-2.27.4.new/data/PreSession.in
22--- gdm-2.27.4/data/PreSession.in       2009-05-19 17:18:12.000000000 +0200
23+++ gdm-2.27.4.new/data/PreSession.in   2009-08-11 19:09:36.000000000 +0200
24@@ -7,3 +7,9 @@
25 # Note that output goes into the .xsession-errors file for easy debugging
26 #
27 PATH="@X_PATH@:$PATH:/bin:/usr/bin"
28+
29+if [ -x '/usr/bin/xsplash' ];
30+then
31+        /usr/bin/xsplash --daemon
32+fi
33+
34diff -Nur -x '*.orig' -x '*~' gdm-2.27.4/gui/simple-greeter/gdm-greeter-session.c gdm-2.27.4.new/gui/simple-greeter/gdm-greeter-session.c
35--- gdm-2.27.4/gui/simple-greeter/gdm-greeter-session.c 2009-07-20 03:06:16.000000000 +0200
36+++ gdm-2.27.4.new/gui/simple-greeter/gdm-greeter-session.c     2009-08-11 19:09:40.000000000 +0200
37@@ -426,6 +426,13 @@
38         toggle_panel (session, TRUE);
39         toggle_login_window (session, TRUE);
40 
41+        g_spawn_command_line_async ("dbus-send "
42+                                    "--system --type=method_call "
43+                                    "--dest=com.ubuntu.BootCurtain "
44+                                    "/com/ubuntu/BootCurtain "
45+                                    "com.ubuntu.BootCurtain.SignalLoaded string:gdm",
46+                                    NULL);
47+
48         gdm_profile_end (NULL);
49 
50         return res;
Note: See TracBrowser for help on using the repository browser.