source: proiecte/PPPP/gdm/debian/patches/10_xsplash.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 1.8 KB
  • data/Init.in

    #
    # Description: Load xsplash on login
    # Ubuntu: https://wiki.ubuntu.com/DesktopTeam/Specs/Karmic/LoginExperience
    #
    === modified file 'data/Init.in'
    diff -Nur -x '*.orig' -x '*~' gdm-2.27.4/data/Init.in gdm-2.27.4.new/data/Init.in
    old new  
    66PATH=@X_PATH@:$PATH
    77OLD_IFS=$IFS
    88
     9if [ -x '/usr/bin/xsplash' ];
     10then
     11        /usr/bin/xsplash --gdm-session --daemon
     12fi
     13
    914gdmwhich () {
    1015  COMMAND="$1"
    1116  OUTPUT=
  • data/PreSession.in

    diff -Nur -x '*.orig' -x '*~' gdm-2.27.4/data/PreSession.in gdm-2.27.4.new/data/PreSession.in
    old new  
    77# Note that output goes into the .xsession-errors file for easy debugging
    88#
    99PATH="@X_PATH@:$PATH:/bin:/usr/bin"
     10
     11if [ -x '/usr/bin/xsplash' ];
     12then
     13        /usr/bin/xsplash --daemon
     14fi
     15
  • gui/simple-greeter/gdm-greeter-session.c

    diff -Nur -x '*.orig' -x '*~' gdm-2.27.4/gui/simple-greeter/gdm-greeter-session.c gdm-2.27.4.new/gui/simple-greeter/gdm-greeter-session.c
    old new  
    426426        toggle_panel (session, TRUE);
    427427        toggle_login_window (session, TRUE);
    428428
     429        g_spawn_command_line_async ("dbus-send "
     430                                    "--system --type=method_call "
     431                                    "--dest=com.ubuntu.BootCurtain "
     432                                    "/com/ubuntu/BootCurtain "
     433                                    "com.ubuntu.BootCurtain.SignalLoaded string:gdm",
     434                                    NULL);
     435
    429436        gdm_profile_end (NULL);
    430437
    431438        return res;
Note: See TracBrowser for help on using the repository browser.