source: proiecte/PPPP/gdm/debian/patches/07_correct_distribution_version.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 1.1 KB
RevLine 
[134]1#
2# Description: use lsb informations to correctly display the distribution
3# Upstream: http://bugzilla.gnome.org/show_bug.cgi?id=589549
4# Ubuntu: https://bugs.launchpad.net/bugs/396805
5#
6--- ./gdm-2.27.4/gui/simple-greeter/gdm-greeter-login-window.c.gnome    2009-07-23 23:12:50.000000000 +0200
7+++ ./gdm-2.27.4/gui/simple-greeter/gdm-greeter-login-window.c  2009-07-23 23:24:26.000000000 +0200
8@@ -1265,10 +1265,16 @@
9 static char *
10 get_system_version (void)
11 {
12-        char *version;
13+        char *version, *output;
14         int i;
15 
16         version = NULL;
17+        output = NULL;               
18+
19+        if (g_spawn_command_line_sync ("lsb_release -sd", &output, NULL, NULL, NULL)) {
20+                version = g_strchomp (output);
21+                return version;
22+        }   
23 
24         for (i = 0; known_etc_info_files [i]; i++) {
25                 char *path1;
26@@ -1289,8 +1295,6 @@
27         }
28 
29         if (version == NULL) {
30-                char *output;
31-                output = NULL;
32                 if (g_spawn_command_line_sync ("uname -sr", &output, NULL, NULL, NULL)) {
33                         version = g_strchomp (output);
34                 }
Note: See TracBrowser for help on using the repository browser.