source: proiecte/PPPP/gdm/debian/patches/07_correct_distribution_version.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 1.1 KB
  • ./gdm-2.27.4/gui/simple-greeter/gdm-greeter-login-window.c

    #
    # Description: use lsb informations to correctly display the distribution
    # Upstream: http://bugzilla.gnome.org/show_bug.cgi?id=589549
    # Ubuntu: https://bugs.launchpad.net/bugs/396805
    #
    old new  
    12651265static char *
    12661266get_system_version (void)
    12671267{
    1268         char *version;
     1268        char *version, *output;
    12691269        int i;
    12701270
    12711271        version = NULL;
     1272        output = NULL;               
     1273
     1274        if (g_spawn_command_line_sync ("lsb_release -sd", &output, NULL, NULL, NULL)) {
     1275                version = g_strchomp (output);
     1276                return version;
     1277        }   
    12721278
    12731279        for (i = 0; known_etc_info_files [i]; i++) {
    12741280                char *path1;
     
    12891295        }
    12901296
    12911297        if (version == NULL) {
    1292                 char *output;
    1293                 output = NULL;
    12941298                if (g_spawn_command_line_sync ("uname -sr", &output, NULL, NULL, NULL)) {
    12951299                        version = g_strchomp (output);
    12961300                }
Note: See TracBrowser for help on using the repository browser.