source: proiecte/PPPP/gdm/debian/patches/05_initial_server_on_vt7.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 1.0 KB
RevLine 
[134]1#
2# Description: Force initial X server to go to tty7 instead of tty1. This is an Ugly Hack until we have a cleaner solution for getty not to tramp over a running X server on vt1.
3# Ubuntu: https://launchpad.net/bugs/396226
4#
5diff -Nur -x '*.orig' -x '*~' gdm-2.26.1/daemon/gdm-server.c gdm-2.26.1.new/daemon/gdm-server.c
6--- gdm-2.26.1/daemon/gdm-server.c        2009-07-09 15:33:58.281094408 +0200
7+++ gdm-2.26.1.new/daemon/gdm-server.c        2009-07-09 15:37:40.697075106 +0200
8@@ -674,9 +674,16 @@
9 gdm_server_start (GdmServer *server)
10 {
11         gboolean res;
12+        int f;
13+
14+        /* HACK: force initial server to go on vt7, since 1 to 6 usually get
15+         * gettys after gdm startup, which interfere with X */
16+        f = open ("/var/run/gdm/firstserver.stamp", O_CREAT|O_WRONLY|O_EXCL, 0666);
17+        if (f > 0)
18+                close (f);
19 
20         /* fork X server process */
21-        res = gdm_server_spawn (server, NULL);
22+        res = gdm_server_spawn (server, (f > 0) ? "vt7" : NULL);
23 
24         return res;
25 }
Note: See TracBrowser for help on using the repository browser.