source: proiecte/PPPP/gdm/debian/patches/05_initial_server_on_vt7.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 1.0 KB
  • daemon/gdm-server.c

    #
    # Description: Force initial X server to go to tty7 instead of tty1. This is an Ugly Hack until we have a cleaner solution for getty not to tramp over a running X server on vt1.
    # Ubuntu: https://launchpad.net/bugs/396226
    #
    diff -Nur -x '*.orig' -x '*~' gdm-2.26.1/daemon/gdm-server.c gdm-2.26.1.new/daemon/gdm-server.c
    old new  
    674674gdm_server_start (GdmServer *server)
    675675{
    676676        gboolean res;
     677        int f;
     678
     679        /* HACK: force initial server to go on vt7, since 1 to 6 usually get
     680         * gettys after gdm startup, which interfere with X */
     681        f = open ("/var/run/gdm/firstserver.stamp", O_CREAT|O_WRONLY|O_EXCL, 0666);
     682        if (f > 0)
     683                close (f);
    677684
    678685        /* fork X server process */
    679         res = gdm_server_spawn (server, NULL);
     686        res = gdm_server_spawn (server, (f > 0) ? "vt7" : NULL);
    680687
    681688        return res;
    682689}
Note: See TracBrowser for help on using the repository browser.