source: proiecte/PPPP/gdm/debian/rules @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

  • Property svn:executable set to *
File size: 1.7 KB
Line 
1#!/usr/bin/make -f
2
3include /usr/share/cdbs/1/rules/debhelper.mk
4include /usr/share/cdbs/1/rules/simple-patchsys.mk
5include /usr/share/cdbs/1/class/gnome.mk
6include /usr/share/gnome-pkg-tools/1/rules/gnome-version.mk
7-include /usr/share/gnome-pkg-tools/1/rules/gnome-get-source.mk
8
9#LDFLAGS += -Wl,-z,defs -Wl,-O1 -Wl,--as-needed
10
11DEB_CONFIGURE_EXTRA_FLAGS += --disable-scrollkeeper --with-at-spi-registryd-directory=/usr/lib/at-spi --enable-ipv6=yes
12
13DEB_DH_INSTALLINIT_ARGS = --no-start
14
15ifeq (linux,$(DEB_HOST_ARCH_OS))
16        DEB_CONFIGURE_EXTRA_FLAGS += --with-selinux
17else
18        DEB_CONFIGURE_EXTRA_FLAGS += --without-selinux
19endif
20
21binary-post-install/gdm::
22        install -m644 debian/gdm-autologin.pam debian/gdm/etc/pam.d/gdm-autologin
23        install -m644 debian/gdm.pam debian/gdm/etc/pam.d/gdm
24        install -D -m644 debian/xterm.desktop debian/gdm/usr/share/xsessions/xterm.desktop
25        rm -r debian/gdm/var/gdm debian/gdm/var/run
26        # move custom.conf to the examples
27        mkdir -p debian/gdm/usr/share/doc/gdm/examples
28        mv debian/gdm/etc/gdm/custom.conf debian/gdm/usr/share/doc/gdm/examples
29        mv debian/gdm/usr/lib/bonobo/servers/GNOME_FastUserSwitchApplet.server debian/gdm/usr/lib/bonobo/servers/GNOME_FastUserSwitchAppletGdm.server
30        # install default settings
31        mkdir debian/gdm/var/lib/gdm/.gconf.defaults
32        install -m 664 debian/%gconf-tree.xml debian/gdm/var/lib/gdm/.gconf.defaults
33        # we install onboard (debian/onboard.desktop), and do not have gok
34        install -m 644 debian/onboard.desktop debian/gdm/usr/share/gdm/autostart/LoginWindow/
35        rm debian/gdm/usr/share/gdm/autostart/LoginWindow/gok.desktop
36        # we do not currently need a PK agent in the gdm session
37        rm debian/gdm/usr/share/gdm/autostart/LoginWindow/polkit-gnome-authentication-agent-1.desktop
38
Note: See TracBrowser for help on using the repository browser.