source: proiecte/PPPP/gdm/debian/patches/19_no_greeter_for_autologin.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 1.1 KB
  • daemon/gdm-simple-slave.c

    #
    # Description: gdm_slave_get_timed_login_details() does not fill variables if username is NULL
    # Ubuntu: https://bugs.edge.launchpad.net/ubuntu/+source/gdm/+bug/435801
    # Upstream: https://bugzilla.gnome.org/show_bug.cgi?id=596830
    #
    diff -Nur -x '*.orig' -x '*~' gdm-2.28.0/daemon/gdm-simple-slave.c gdm-2.28.0.new/daemon/gdm-simple-slave.c
    old new  
    10141014        if (res) {
    10151015                gboolean enabled;
    10161016                int      delay;
     1017                char    *username;
    10171018
    10181019                /* FIXME: handle wait-for-go */
    10191020
     
    10211022
    10221023                delay = 0;
    10231024                enabled = FALSE;
    1024                 gdm_slave_get_timed_login_details (GDM_SLAVE (slave), &enabled, NULL, &delay);
     1025                gdm_slave_get_timed_login_details (GDM_SLAVE (slave), &enabled, &username, &delay);
     1026                g_free (username);
    10251027                if (! enabled || delay > 0) {
    10261028                        start_greeter (slave);
    10271029                        create_new_session (slave);
Note: See TracBrowser for help on using the repository browser.