source: proiecte/PPPP/gdm/debian/patches/17_use_timed_login_after_autologin.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 760 bytes
RevLine 
[134]1#
2# Description: Revert upstream change to not use timed login after autologin session
3# Ubuntu: https://bugs.edge.launchpad.net/ubuntu/+source/gdm/+bug/396489
4#
5diff -Nur -x '*.orig' -x '*~' gdm-2.28.0/daemon/gdm-static-display.c gdm-2.28.0.new/daemon/gdm-static-display.c
6--- gdm-2.28.0/daemon/gdm-static-display.c      2009-09-21 22:05:27.000000000 +0200
7+++ gdm-2.28.0.new/daemon/gdm-static-display.c  2009-09-22 17:46:19.000000000 +0200
8@@ -121,6 +121,9 @@
9 {
10         g_return_val_if_fail (GDM_IS_DISPLAY (display), FALSE);
11 
12+        /* Only allow timed/automatic login once */
13+        GDM_STATIC_DISPLAY (display)->priv->enable_timed_login = FALSE;
14+
15         GDM_DISPLAY_CLASS (gdm_static_display_parent_class)->unmanage (display);
16 
17         return TRUE;
Note: See TracBrowser for help on using the repository browser.