source: proiecte/PPPP/gdm/debian/patches/15_default_session.patch @ 134

Last change on this file since 134 was 134, checked in by (none), 14 years ago

gdm sources with the modifications for webcam

File size: 756 bytes
RevLine 
[134]1#
2# Description: Prefer "default.session", so that other desktop environments like XFCE can use gdm, too, without being forced to start GNOME.
3# Ubuntu: https://launchpad.net/bugs/403291
4# Upstream: https://bugzilla.gnome.org/show_bug.cgi?id=594733
5#
6--- gdm-2.27.90/daemon/gdm-session-direct.c     2009-09-10 12:26:43.919455898 +0200
7+++ gdm-2.27.90.new/daemon/gdm-session-direct.c 2009-09-10 12:27:03.007456454 +0200
8@@ -668,6 +668,11 @@
9         int           i;
10         char         *name;
11 
12+        name = g_strdup ("default");
13+        if (get_session_command_for_name (name, NULL)) {
14+                return name;
15+        }
16+
17         name = g_strdup ("gnome");
18         if (get_session_command_for_name (name, NULL)) {
19                 return name;
Note: See TracBrowser for help on using the repository browser.